Our Support chat app is down
Incident Report for Cucumber
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 15:35 UTC
Investigating
Our provider is experiencing troubles currently so we can't be contacted through the chat widget.

We'll answer your requests as soon as possible!

Thanks for your patience.

Our apologies for this inconvenience =(

You can also reach out to our support team by email at: studio@cucumber.io
Posted Jan 17, 2020 - 15:21 UTC
This incident affected: CucumberStudio (CucumberStudio Application).